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Fiji is a popular free open-source image processing package based on Imagel, https://imagej.net/Fiji. We demonstrate
how to use Fiji User Interface and OMERO and we also demonstrate how to analyze data in OMERO using Fiji scripting
facility.
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CHAPTER
ONE

INSTALL THE PLUGINS

1.1 How to install OMERO plugins for Fiji/lmageJ

1.1.1 Description

Fiji is a free open-source image processing package based on ImageJ. The following workflow shows how to install the
OMERO plugin for Fiji and Imagel.

The OMERO plugin does not have an update site yet.

1.1.2 Setup step-by-step

We assume that you have already Fiji/Image] installed locally. If not, download Fiji.

In this section, we will cover the steps required to install the OMERO plugin for Fiji. If you wish to install it for ImageJ,
an additional step is needed.

We first describe the common installation steps for Image]J and Fiji. We then describe how to install the Bio-Formats
Package for Imagel].

Installing the OMERO plugin in Fiji also adds the dependencies required to connect to OMERO using the Script Editor
of Fiji.

Installation of the OMERO plugin for Fiji and ImageJ

Below are the common steps that need to be followed:

* Find the Plugins folder of your Fiji application and check if it contains any old omero_ij-5.x.x-all.jar file(s) or
OMERO.imagej-5.x.x folder(s). Remove any such jar files or folders from the Plugins folder.

* Download from https://www.openmicroscopy.org/omero/downloads the latest 5.x.x version of ImageJ/Fiji plugin
for OMERO



https://imagej.net/Fiji
https://imagej.net/software/fiji/downloads
https://www.openmicroscopy.org/omero/downloads
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* For recent plugin versions (5.5.7 and higher): Note where you downloaded the omero_ij-5.x.x-all.jar file. Copy
that file into the plugins folder of Fiji.

* For plugin versions lower than 5.5.7: Extract the downloaded .zip archive. Remember where you extracted it to.
* For plugin versions lower than 5.5.7: Copy the extracted folder and paste it to the plugins folder of Fiji.

* Note: For plugin versions lower than 5.5.7: Some Windows unzip apps create a double folder enclosing the
plugin. If that is the case, copy the inner OMERO.imagej-5.x.x folder into Fiji.app > plugins folder.

* Now, restart Fiji. If you are using ImagelJ, follow with the additional step below.

4 Chapter 1. Install the plugins
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Installation of Bio-Formats Package, Imaged only

* Download the latest version of the Bio-Formats Package from: https://www.openmicroscopy.org/bio-formats/
downloads

Bio-Formats 6.2.0 Downloads

Read The Release Announcement

Read the Docs
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> < 3 3
S >-
Bio-Formats Package Command Line Tools MATLAB Toolbox Octave Package
The compl ndle for end A bundle of scripts for using
S C erything
mage| are availab
user guide
- \ / \ \ \

* Move the downloaded file into the ImageJ > plugins folder.

* Restart Imagel.

Installation of the plugins to interact with OMERO using the ImageJ marco language
The plugins are developed and supported by Institute of genetics, reproduction & development (iGReD) in Clermont-
Ferrand (France).

* Download the latest version of simple-omero-client from https://github.com/GReD-Clermont/
simple-omero-client:

— Click on the Tags tab
— Click on the most recent tag
— Download the simple-omero-client-<tag>. jar file e.g. simple-omero-client-5.14.1.jar

e Download the latest version of omero_macro-extensions from https://github.com/GReD-Clermont/omero_
macro-extensions:

— Click on the Tags tab

— Click on the most recent tag
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— Download the omero_macro-extensions-<tag>.jar file e.g. omero_macro-extensions-1.3.2.
jar
* Move the downloaded jars into the Fiji > plugins folder.

* Restart Fiji.
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CHAPTER
TWO

MANUAL ANALYSIS

2.1 Crop and import

2.1.1 Description
The following workflows should work both with ImageJ and Fiji, after these have been correctly set up with the OMERO
plugin for Fiji/Image].
Using the User Interface of the OMERO plugin, we will show:
* How to connect to OMERO using the OMERO plugin for ImagelJ/Fiji.
* How to open an image from OMERO.server into Fiji/ImageJ.

* How to import the cropped image from Fiji/ImageJ into OMERO.

2.1.2 Setup

* Install Fiji on the local machine with the OMERO.insight-ij plugin. The installation instructions can be found at
How to install OMERO plugins for Fiji/lmageJ .

2.1.3 Resources

» Samples images from the Image Data Resource (IDR) idr0021.

2.1.4 Step-by-step

In this example, we show how to open an OMERO image, crop the image and import the cropped image back to
OMERO as OME-TIFF.

1. Launch Fiji/Imagel.

2. Go to Plugins > OMERO > Connect To OMERO. This will show a login screen where you can enter the name
of the server to connect to, the username and password. The OMERO plugin will allow you to browse your data
in a similar manner to OMERO.web.

3. In the OMERO login dialog, click the wrench icon " and then add the server address in the dialog. By default,
only “localhost” is listed. Click on the plus icon to add a new line to the list and type into the line the server
address.



https://idr.openmicroscopy.org/search/?query=Name:idr0021
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4. Click Apply.
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Enter your credentials and click Login.

Select a dataset, for example the A-Fiji-dataset Dataset.

Double-click on a thumbnail or on an Image in the left-hand tree to open an Image in Fiji/ImageJ.

Draw a Rectangle on the Image.

Select the option Image > Crop.

A new Image will be displayed in a Fiji/ImageJ window.

Go to Plugins > OMERO > Save Image(s) To OMERO.

An Import dialog will pop up.

d monitor imports.

Select Datato Import |+ Import #1 @
Select where to import the image(s).
Group o Labl o
Import For trainer-1 trainer-1 <
W - --- B Screens
Project --No Project--
Dataset --No Dataset--

* Add Image from current window
Add Images from all image windows

Import Data
25 Options
Free Space [ ] Import size:
File or 0 Project/ Folder a
Folder S ’ or 5c Datase’
o] New... <
< New... «

Refresh

Close

Add to the Queue

Cancel All

4064
4064
Low (Dial-up)
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13.
14.

15.
16.
17.

Check that the option Add Image from current window is selected.

Select where to import the cropped Image, for example an existing Dataset, e.g. A-Fiji-dataset. You can also
select New From Folder option which will create a new Dataset named with the name of the image you opened
from OMERO to Fiji. In case you select No Dataset option, the new image will be displayed in the Orphaned
Images folder in OMERO.

Click Add to the Queue button.
Then click Import. The import will start.

When the import is done, go back to the Tree view in the Fiji plugin or OMERO.web. Refresh. Check the new
Image.

2.2 Analyze, save ROIs and measurements

2.2.1 Description

The following workflows should work both with ImageJ and Fiji, after these have been correctly set up with the OMERO
plugin for Fiji/Imagel.

Using the User Interface of the OMERO plugin, we will show:

¢ How to connect to OMERO using the OMERO plugin for ImagelJ/Fiji.

* How to open an image from OMERO.server into Fiji/ImageJ.

* How to manually save ROIs and measurements as CSV back to the original image in OMERO.server.

* How to import a newly created image from Fiji/ImageJ into OMERO.

2.2.2 Setup

¢ Install Fiji on the local machine with the OMERO.insight-ij plugin. The installation instructions can be found at

How to install OMERO plugins for Fiji/lmageJ .

2.2.3 Resources

» Samples images from the Image Data Resource (IDR) idrO021.

2.2.4 Step-by-step

In this first example we show how to open an OMERO image in Fiji, draw ROIs, measure those ROIs and show how to
save the ROIs and the measurement back to OMERO.

1.
2.

Launch Fiji/Image].

Go to Plugins > OMERO > Connect To OMERO. This will show a login screen where you can enter the name
of the server to connect to, the username and password. The OMERO plugin will allow you to browse your data
in a similar manner to OMERO.web.

. In the OMERO login dialog, click the wrench icon " and then add the server address in the dialog. By default,

only “localhost” is listed. Click on the plus icon to add a new line to the list and type into the line the server
address.

2.2,
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4. Click Apply.
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Enter your credentials and click Login.

Select the A-Fiji-dataset Dataset.

Double-click on a thumbnail or on an Image in the left-hand tree to open an Image in Image].
Go to Analyze > Tools > ROI Manager. ..

Draw a shape using for example the Freehand selection tool.

In the ROI manager, click the button Add [t] to add the shape to the ROI Manager.

Centrin_PCNT_Cep215_20110... ROI Manager
1/3 (c:1/3 - Centrin_PCNT_Cep215_2011[4401-0067-0087 Add [t]
Update
Delete
Rename...
Measure
Deselect
Properties...
Flatten [F]
More »
Show All
¢ Labels
11. Move to another channel, using the c slider.
12. Draw other shapes if desired. Click Add [t] to add them to the ROI Manager.
13. When done with the drawing, click the button Measure in the ROI Manager.
14. A dialog with measurements for each shape pops up.
15. To save the ROI and the measurement back to OMERO, go to Plugins > OMERO > Save ROIs To OMERO.
16. In the dialog popping up, under the Save section select ROl and Measurements.
10 Chapter 2. Manual Analysis
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17. The measurements are saved back to OMERO as a CSV file and linked to the Image.

Save ImageJ results

Save results for
® |mage from current window

Images from all image windows

Save
v ROI

v Measurements

Measurements File Name:

Save Cancel

18. Go to OMERO.web and log in.
19. Select the image opened in Fiji/Image].
20. Check that there is a new CSV file under the Attachments harmonica.

21. Open the image in OMERO.iviewer to the see the ROIs and make sure that you can interact with them.

2.3 Manual Segmentation

2.3.1 Description
The following workflows should work both with ImageJ and Fiji, after these have been correctly set up with the OMERO
plugin for Fiji/Image].
Using the User Interface of the OMERO plugin, we will show:
* How to connect to OMERO using the OMERO plugin for Fiji/Image].
* How to open an image from OMERO.server into Fiji/ImageJ.

* How to manually segment an image opened from OMERO in Fiji/ImageJ using the plugins Auto Threshold and
Analyze particles in Fiji/Image].

* How to record this workflow in Fiji/ImageJ, using the Recorder plugin, for later use.

2.3.2 Setup

* Fiji has been installed on the local machine with the OMERO.insight-ij plugin. The installation instructions can
be found at How to install OMERQO plugins for Fiji/lmagelJ.

2.3. Manual Segmentation 11
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2.3.3 Resources

» Samples images from the Image Data Resource (IDR) idrO021.

2.3.4 Step-by-step

1. Launch Fiji/Image].

2. Go to Plugins > OMERO > Connect To OMERO. This will show a login screen where you can enter the name
of the server to connect to, the username and password. The OMERO plugin will allow you to browse your data
in a similar manner to OMERO.web.

3. In the OMERO login dialog, click the wrench icon ™ and then add the server address in the dialog. By default,
only “localhost” is listed. Click on the plus icon to add a new line to the list and type into the line the server
address.

4. Click Apply.

L =N Servers

Servers
Enter a new server or %
select an existing one.

¢+ OMERO

Server
e.g. te.

.J joutreach.openmicroscopy.org 4064

ocalhost  [HighI J localhost 4064

Username: |user-1

=S
L Legin Quit Connection Speed
© High (LAN) Medium (Broadband) Low (Dial-up)

W coce

5. Enter your credentials and click Login.

6. Browse to the Project idr0021, open any Dataset and double-click once on an Image to open it in Fiji. Bio-
Formats is used to view the Image.

* Make sure to select View stack with: Hyperstack in the Bio-Formats Import Options dialog.
* Note that each plane will be transferred from the server to the client machine so this may take a few moments.

7. To open the Recorder, go Plugins > Macros > Record. .., select Macros to record the actions. The steps will
then be used in the Scripting workflow.

8. Convert floating-point pixel-type to 8-bit using Image > Type > 8-bit.

9. Go to Image > Adjust > Auto Threshold, to open the Auto Threshold dialog:
* Select MaxEntropy for the Method parameter.
* Check the checkbox Stack.

12 Chapter 2. Manual Analysis
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O Auto Threshold

Auto Threshold v1.16.4

Method  MaxEntro B
i B @ O @ Centrin_PCNT_Cep215_201...

1/3 (c:1/3 - Centrin_PCNT_Cep215_2011

Ignore black Ignore white
White objects on black background
SetThreshold instead of Threshold (single images)
Show threshold values in log window
Stack
Use stack histogram an

The thresholded result of 8 & 16 bit images is shown
in white [255] in 8 bits.

For 16 bit images, results of 'Try all' and single slices
of a stack are shown in white [65535] in 16 bits.
Unsuccessfully thresholded images are left unchanged.

Cancel OK

10. Click OK.
11. Then open Analyze > Analyze Particles. ...
12. In the dialog
* Set Size to 10-Infinity and check Pixel units.
* Check the following checkboxes:
i. Display results
ii. Clear results
iii. Add to Manager

¢ Click OK then Yes in the popup dialog indicating asking to
Process all X images?.

-

o Analyze Particles

Size (micronA2): 10-Infinity
Pixel units

Circularity: 0.00-1.00

Show: Nothing E
Display results Exclude on edges
Clear results Include holes
Summarize Record starts
Add to Manager In situ Show
Help Cancel OK

L

13. To save the thresholded Image back to OMERO with the generated ROIs and the measurements:
e Select Plugins > OMERO > Save Image(s) to OMERO.

2.3. Manual Segmentation 13
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* Create a New Dataset for the image
i. Click the New... button next to the selection box on the Dataset row.
ii. In the dialog that pops up, enter a name and a description (optional).
iii. Click Create.
* The newly created Dataset will automatically be selected.

Click Add to the Queue then Import.

¢ Go to OMERO.web and check that the measurements have been saved in a CSV file and attached to the
Images. The attachment can then be downloaded at any time.

14. To save the recorded macro to OMERO.server:

* In Fiji, find the Recorder window and click “Create”. A new window will pop up with the macro you
just recorded. Verify the macro on a new image. Once the verification succeeds, just close the macro
window and in the dialog which pops up select “Yes” to save the macro. Save the macro locally e.g.
“your-macro-name.ijm”.

* In OMERO.web, select the dataset you would like the macro to be run on and attach the “your-macro-
name.ijm” macro you just recorded as file attachment to that dataset. The attachment can then be
downloaded at any time. Also, the attached macro can be used by Fiji scripts - see example on thresh-
old_scripting.html.

14 Chapter 2. Manual Analysis
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CHAPTER
THREE

AUTOMATED ANALYSIS

3.1 Segment using ImagedJ Macro language

3.1.1 Description

The following workflows should work in Fiji, after it has been correctly set up with the OMERO plugin for Fiji/Imagel.

In this section we use the ImageJ macro language to access data in OMERO. To interact with OMERO using the Image]J
macro language, two extra plugins need to be installed.

Using the Scripting editor of Fiji, we will show:
* How to connect to OMERO..
* How to load all the images within a given Dataset.
* How to load the images in ImageJ using Bio-Formats.
* How to analyze the images using Auto Threshold and Analyze particles plugins in ImageJ within a script.
* How to save the segmented ROIs as polygons in OMERO.
* How to collect the measurement associated to the ROIs and
— Save them as an OMERO.table and link the table to the Dataset.

— Save them as a CSV file and link it to the Dataset.

3.1.2 Setup
* Install Fiji on the local machine with the OMERO.insight-ij plugin. The installation instructions can be found at
How to install OMERQO plugins for Fiji/lmageJ .

¢ Install the two plugins required to use the macro language. Instructions can be found at Installation of the plugins
to interact with OMERO using the ImageJ marco language.

15
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3.1.3 Resources

» Data: Samples images from the Image Data Resource (IDR) idr0021.

e Script: Image] macro language script for automatic segmentation of images from OMERO using Fiji -
analyse_dataset_save_rois_and_summary_table.ijm.

* More examples on how to use the Image] Macro language and OMERO can be found at macro extension exam-
ples.

3.1.4 Step-by-Step

We will now repeat the manual analysis Manual Segmentation on a Dataset using the scripting facility available in Fiji.
Let’s go over the script to understand the logic and see how it matches the UI steps.

It will process all the Images in the specified Dataset, applying threshold, analyzing particles and saving ROIs back in
OMERO i.e. we reproduce in a script the manual steps recorded. Further, it will create a CSV and OMERO.table to be
attached to that Dataset in OMERO.

1. In your browser, go to the server address provided.
2. Log in using the credentials provided.
3. Make sure you are selecting your own data. Select the Dataset A-Fiji-dataset.
4. Launch Fiji.
5. Go to File > New > Script....
6. A dialog pops up. In the Language menu, select ImageJ macro if not already selected.
7. Copy, into the text script editor of Fiji, analyse_dataset_save_rois_and_summary_table.ijm.
8. You will be asked to enter your login credentials when you run the script.
9. Click Run.
10. Return to OMERO.web and open an Image from this Dataset in OMERO.iviewer.

—
—

. Click the ROIs tab to see the added ROIs. Note that the ROIs have been assigned a Channel index to indicate
which Channel they were derived from.

12. In the Settings tab, turning channels on/off will also show/hide ROIs assigned to those channels.

3.2 Segment using Groovy script

3.2.1 Description
The following workflows should work in Fiji, after these have been correctly set up with the OMERO plugin for
Fiji/Image].
Using the Scripting editor of Fiji, we will show:
* How to connect to OMERO using the JAVA APIL.
* How to load all the images within a given Dataset.
* How to load the images in ImageJ using Bio-Formats.

* How to analyze the images using Auto Threshold and Analyze particles plugins in Image] within a script.

16 Chapter 3. Automated Analysis
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* How to save the segmented ROIs as polygons in OMERO.

* How to collect the measurement associated to the ROIs and
— Save them as an OMERO.table and link the table to the Dataset.
— Save them as a CSV file and link it to the Dataset.

3.2.2 Setup

* Install Fiji on the local machine with the OMERO.insight-ij plugin. The installation instructions can be found at
How to install OMERO plugins for Fiji/lmageJ .

3.2.3 Resources

* Data: Samples images from the Image Data Resource (IDR) idrO021.
* Java API documentation.

* Script: Groovy script for automatic segmentation of images from OMERO using Fiji -
analyse_dataset_save_rois_and_summary_table.groovy.

3.2.4 Step-by-Step

We will now repeat the manual analysis Manual Segmentation on a Dataset using the scripting facility available in Fiji.
Let’s go over the script to understand the logic and see how it matches the UI steps.
This script explores the JAVA API using Groovy.

It will process all the Images in the specified Dataset, applying threshold, analyzing particles and saving ROIs back in
OMERO i.e. we reproduce in a script the manual steps recorded. Further, it will create a CSV and OMERO.table to be
attached to that Dataset in OMERO.

1. In your browser, go to the server address provided.
. Log in using the credentials provided.
. Make sure you are selecting your own data. Select the Dataset A-Fiji-dataset.
. Launch Fiji.

. Go to File > New > Script....

2
3
4
5
6. A dialog pops up. In the Language menu, select Groovy.
7. Copy, into the text script editor of Fiji, analyse_dataset_save_rois_and_summary_table.groovy.
8. You will be asked to enter your login credentials when you run the script.

9. Click Run.

10. Return to OMERO.web and open an Image from this Dataset in OMERO.iviewer.

11. Click the ROIs tab to see the added ROIs. Note that the ROIs have been assigned a Channel index to indicate
which Channel they were derived from.

12. In the Settings tab, turning channels on/off will also show/hide ROIs assigned to those channels.

13. Open the image in OMERO.figure for a quick publication by going to Info tab in iviewer and clicking on

Open With: OMERO.figure |
OMERQO. .figure in the Open with line.

3.2. Segment using Groovy script 17
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CHAPTER
FOUR

FIJI AND ZARR

4.1 View zarr file using MoBIE and BDV

4.1.1 Description

This section shows how to view ome.zarr files in Fiji using MoBIE.
We show:
* how to install the required dependencies
* how to view an ome.zarr file stored in S3 using the User Interface

* how to view an ome.zarr file stored in S3 using the scripting editor of Fiji.

4.1.2 Setup

* Install Fiji on a local machine.
¢ Go to Help>Update...
¢ In the ImageJ updater dialog, click on Manage update sites.
* The MoBIE " should already be listed. Select it and click Close.
e Click Apply changes to install it.
o If MoBIE " is not listed:

— Click Add update site.

— Enter for the name MoBIE (so you can identify it) and for the URL: https://sites.imagej.net/
MoBIE/. See How to install an update site.

— Click Apply changes to install it.

* Restart Fiji.

19
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4.1.3 Resources
» Samples images from the Image Data Resource (IDR) that have been converted into https://github.com/ome/ngft.
A list of available files can be found here.
¢ Script: Groovy script for opening the images in BigDataViewer using MoBIE.
— mobie_ome_zarr.groovy.

* Watch an introductory video.

4.1.4 Step-by-step
Opening an ome.zarr file from the User Interface

1. Launch Fiji.

2. Go to Plugins > BigDataViewer > OME ZARR > Open OME ZARR from S3....

3. A dialog pops up.

4. In the text field, enter the desired URL e.g.
https://ukls3.embassy.ebi.ac.uk/idr/zarr/v0.1/9836832.zarr

1. Click the OK button.

2. When the image is displayed in the BigDataViewer, select the dialog and press P to display the rendering controls.

3. Modify the settings as you see fit.

Opening an ome.zarr file using a Groovy script

1. Launch Fiji.

Go to File > New > Script....

A dialog pops up. In the Language menu, select Groovy.

Copy the content of mobie_ome_zarr.groovy and paste it into the text script editor of Fiji.
Click Run.

When the image is displayed in the BigDataViewer, select the dialog and press P to display the rendering controls.

NS A » N

Modify the settings as you see fit.

4.2 Contribute

Changes to the documentation or the materials should be made directly in the omero-guide-fiji repository.

20 Chapter 4. Fiji and Zarr


https://github.com/ome/ngff
https://idr.github.io/ome-ngff-samples/
https://www.youtube.com/watch?v=KposKXm7xeg
https://github.com/ome/omero-guide-fiji

OMERO guide Fiji Documentation, Release 0.2.1

4.2.1 Segment OMERO data using Fiji run headlessly in notebook

Description

The following examples follow up on the script shown in Segment using Groovy script. But, unlike in Segment using
Groovy script, here, Fiji is included into a Docker image and run in headless mode. The scripts are embedded into a
Jupyter Notebook. The Groovy language is used, which is very similar to Java and can be used in Fiji scripting. The
scripts show:

* How to run a Fiji macro attached to an OMERO Dataset, save ROIs, Results and Images (as OME-TIFF) to
OMERO

* How to crop an image in OMERO using Fiji cropping functionality.

Setup

Fiji has been installed in a Docker image using repo2docker.

Resources

* Data: Samples images from the Image Data Resource (IDR) idr0021.

e Macro: fiji-macro-segment.ijm

Step-by-Step
1. Create a Fiji macro, for example by recording it and save it locally. You can for example use adjusted macro
created in Manual Segmentation. See £iji-macro-segment.ijm.

Note: Not all commands which can be run and recorded in the Fiji user interface can be also run in the Fiji in
headless mode.

. In your browser, go to the server address provided.
. Log in using the credentials provided.

. Make sure you are selecting your own data. Select the Dataset A-Fiji-dataset.

1L VS I

. Open the Attachments harmonica in the right-hand panel and click on the plus icon. Browse and attach the
fiji-macro-segment.ijm to this Dataset as File Annotation.

[*))

. Run the notebook run_attached_macro.ipynb.
7. Select the first Step and click on the Run button to execute each step in turn.

8. For the connection to OMERO, you will be asked to enter your login details when running the first cell under
Description. Note that the connection itself happens only in the next cell, highlighted as Connect to OMERO.

9. In the following cell, you will be asked to enter the ID of the Dataset onto which you attached the Macro file
above.

10. The code in the next cell is fetching the attachments on the Dataset and offering a dropdown menu for you to
select a suitable attachment i.e. your attached macro.

11. The next cell is asking for input about the types of data which should be saved back to OMERO (ROIs, Results
or Images). This is of course dependent on the type of results your Macro is producing in Fiji. For this example,
we select ROIs and Results.
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12. The script in the next cell will process all the Images in the specified Dataset, applying threshold, analyzing
particles, i.e. steps which are captured inside your macro file. Further, it will save ROIs back in OMERO and
create a CSV to be attached to each image in that Dataset in OMERO.

13. Return to OMERO.web and open an Image from this Dataset in OMERO.iviewer.
14. Click the ROIs tab to see the added ROIs.
15. In the Settings tab, turning channels on/off will also show/hide ROIs assigned to those channels.

16. Open the image in OMERO..figure for a quick publication by going to the Info tab in OMERO.iviewer and clicking

Open With: OMERO.figure |
on OMERQO figure in the Open with line.

17. Click the ROIs tab to see the added ROIs. Note that the ROIs have been assigned a Channel index to indicate
which Channel they were derived from.

18. In the Settings tab, turning channels on/off will also show/hide ROIs assigned to those channels.
19. Run the notebook crop_image.ipynb.
20. Run through the notebook, logging in as previously and indicating the Image ID of the image you want to crop.

21. In OMERO.web, refresh and note that the cropped image has been imported into a newly created Dataset Cropped
image.

4.2.2 Analyse data using ImagedJ in Python
Description:

This section shows how to use ImageJ as a Python library to analyze data in OMERO.

Using the Python API allows us to easily load the 2D-plane we need to see or analyze. This is much easier than using
the Java API and Bio-Formats plugin.

We will show in the examples:
* How to start ImageJ in Python.
* How to load data from OMERO.

* How to run ImageJ macro from Python.

Setup
For using the Python examples and notebooks of this guide we recommend using Conda. Conda manages programming
environments in a manner similar to virtualenv.
Install omero-py and pyimagej via Conda:
¢ Install Miniconda if necessary.

* Create a programming environment using Conda and activate it:

$ conda create -n imagej_python python=3.6

$ conda activate imagej_python

* Install omero-py and pyimagej:
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$ conda install -c conda-forge pyimagej

$ conda install -c ome omero-py

Note: we have noticed problems using the Conda approach when running the scripts on some operating systems due
to issues with the ImageJ1-ImageJ?2 bridge.

Step-by-Step
The script used in this document is run_macro_python.py. One of the advantages of this approach is that we can
load only the 2D-planes we wish to analyze.

The script used in this document contains an ImageJ1 macro that needs graphical user interface (GUI) elements, and
thus it requires using ImageJ in GUI mode. In this GUI mode, the resulting windows content is handled.

You will first need to update the script to point to your local installation of Fiji or use one of the options described in
Imagel] Tutorials. You can now run the script. To run the script, go to the folder scripts/python and run:

[$ python run_macro_python.py

If you do not use any ImagelJ1 features e.g. macro, you do not need the UI environment.

Below we explain the various methods in the scripts: how to start Fiji, how to load the planes to analyze and how to
run an ImageJ1 macro.

In this example, Fiji has been installed locally.

Script’s description

Import modules needed:

import imagej
from omero.gateway import BlitzGateway

Load Fiji. If you run the script locally, point to your local installation of Fiji or load Fiji “on the fly”. Note that the
parameter headless has been set to False since we need the graphical user interface to run the ImageJ1 macro:

def start_fijiQ:
ij = imagej.init('/srv/conda/vnc/Fiji.app', headless=False)
ij.getVersion()
return ij

Connect to the server. It is also important to close the connection again to clear up potential resources held on the
server. This is done in the disconnect method:

def connect(hostname, username, password):
Connect to an OMERO server
:param hostname: Host name
:param username: User
(continues on next page)
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def

(continued from previous page)

:param password: Password

:return: Connected BlitzGateway

conn = BlitzGateway(username, password,
host=hostname, secure=True)

conn. connect()

conn.c.enableKeepAlive (60)

return conn

disconnect(conn):

o

Disconnect from an OMERO server
:param conn: The BlitzGateway

e

conn.close()

Load an image from IDR:

[

image = conn.getObject("Image", image_id) ]

Load the binary plane as numpy array:

def

load_plane(image):

Load a 2D-plane as a numpy array
:param image: The image

pixels = image.getPrimaryPixels()
return pixels.getPlane(0, 0, 0)

To be used in Imagel, the numpy array will be converted into ImageJ types using the fo_java() method. In order the
use the methods implemented above in a proper standalone script: Wrap it all up in an analyse method and call it
from main:

def

def

analyse(ij, conn, image_id):

# Step 3 - Load image

image = conn.getObject("Image", image_id)
#_

plane = load_plane(image)

from jnius import autoclass
autoclass('ij.WindowManager"')

ij.ui() .show('Image', ij.py.to_java(plane))
macro = """run("8-bit")"""
ij.py.run_macro(macro)

mainQ):

try:
(continues on next page)
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(continued from previous page)

hostname = input("Host [wss://idr.openmicroscopy.org/omero-ws]: \
") or "wss://idr.openmicroscopy.org/omero-ws"

username = "public"”

password = "public"

image_id = int(input('"Image ID [1884807]: ") or 1884807)
print("initializing fiji...")

ij = start_£fijiQ
print("connecting to IDR...")
conn = connect(hostname, username, password)

print("running the macro...")
analyse(ij, conn, image_id)
finally:
if conn:
disconnect(conn)
if _name__ == "__main__":
main()

4.2. Contribute 25




	Install the plugins
	How to install OMERO plugins for Fiji/ImageJ
	Description
	Setup step-by-step
	Installation of the OMERO plugin for Fiji and ImageJ
	Installation of Bio-Formats Package, ImageJ only
	Installation of the plugins to interact with OMERO using the ImageJ marco language



	Manual Analysis
	Crop and import
	Description
	Setup
	Resources
	Step-by-step

	Analyze, save ROIs and measurements
	Description
	Setup
	Resources
	Step-by-step

	Manual Segmentation
	Description
	Setup
	Resources
	Step-by-step


	Automated Analysis
	Segment using ImageJ Macro language
	Description
	Setup
	Resources
	Step-by-Step

	Segment using Groovy script
	Description
	Setup
	Resources
	Step-by-Step


	Fiji and Zarr
	View zarr file using MoBIE and BDV
	Description
	Setup
	Resources
	Step-by-step
	Opening an ome.zarr file from the User Interface
	Opening an ome.zarr file using a Groovy script


	Contribute
	Segment OMERO data using Fiji run headlessly in notebook
	Description
	Setup
	Resources
	Step-by-Step

	Analyse data using ImageJ in Python
	Description:
	Setup
	Step-by-Step
	Script’s description





